HOWTO: GTA: Chinatown Wars - 100% working, untouched version

Discussion in 'Technical Help' started by iNillus, Mar 28, 2009.

Thread Status:
Not open for further replies.
  1. iNillus

    iNillus New Member

    GTA Chinatown Wars on your DS flashcard: 100% working with no issues AT ALL

    First of all, I'm posting this because I hope it clears up all the vagueness around getting GTA: Chinatown Wars rom to work.
    I own a M3 Real card and this game works 100% for me now. (Wi-fi, multiplayer, no freezes at random points etc)

    Why would you bother reading this?
    Well you might be playing a GTA: Chinatown Wars rom now and think it's all working fine, but if you have a 'patched' or 'fixed' version demonstrated on YouTube, it's likely that you'll get bitten in the ass after a while.

    All the ARM patched versions etc appear to work on first sight ("wow save freezes not anymore!") but have 'hidden issues' like Multiplayer partially not working, Wi-Fi freezes up, game freezes ALWAYS at some occassions etc.

    That's what I experienced and this is how I tackled it.

    Patched and 'fully working version's advertised on YouTube:
    First I downloaded some 121MB version of the game which was 'patched' with an ARM fix and hardcoded cheats, it passed the saving freeze and everything else appeared to work fine BUT multiplayer modes other than LC survivor made it freeze up during the 'Countdown'.

    Original European version + savebypass cheat:
    Then I downloaded the original version of the game (Europe, (E), #3538) and used the ActionReplay cheat for getting through the save freeze: all working, so I played the game and during the mission 'Cash and Burn' I found out that it froze when you used a flamethrower. (also outside of that mission)

    Original USA version + savebypass cheat:
    (Pissed off) I tried the original version of the game (United States, (U)), renamed my savefiles (savefiles for E and U are universal :D), and used same ActionReplay cheat: no save freeze, multiplayer + Wi-Fi 100% and flamethrower working.
    I'm at ~50% in the game now and it works as a charm.

    If you want this game to work 100% on your flashcard with no random freezes, missing features or wutever, follow the steps below.

    - United States version of the game (#3517, released by Xenophobia), direct download from Romulation, no fucked up ARM patched versions that crawl around on YouTube, you'll need the CLEAN and UNTOUCHED #3517 rom.

    - ActionReplay cheat database for your card, all recent cheat dbs ( contain the cheat 'Save bypass' for #3517 which gets the untouched version past the 'zomg it freezes at saveselect'. This freeze just happens on most cards (not on the Cyclo methinks) and you need this cheat to force your card to pass it, patching it up fixes this but fucks up other parts, this doesn't
    LINK: unofficial cheat database thread
    Pick the cheat database matching your card there, they have everything lol. ;D

    - Enable cheatswitch, enable the 'Save bypass' cheat

    - Enjoy this brilliant game with Wi-Fi, Multiplayer and everything else working

    This works as a charm for me and I hope it does for you guys aswell, if it works for you then please spread the word to stop people downloading fucked up versions that work partially.

    Thanks Xenophobia for releasing this ROM.
    Thanks Romulation for hosting this and many other games.

    - Nillus
  2. branraf

    branraf New Member

    Much appreciated about the fact you took your time to write this but this problem has already been solved:

    Most people know about it anyway but it's appreciated that you took your time to write it and sum it up for us. Thanks
  3. iNillus

    iNillus New Member

    Thanks for your reply, but as I posted above I also did this and it DID make my game work, but stuff like most multiplayer modes (except LC survivor) etc made it freeze or behave crap.
    The stuff I'm posting in this thread solved all problems for me (including the nasty side effects of ARM-patching it) so I thought it would be useful.
    I guess you tried the ARM-patching aswell, do multiplayer modes like Defend the base etc freeze during the countdown timer for you? That was what I was experiencing on my ARM-patched version, apart from that it works indeed fine.

    Where the other thread suggests using the USA version of the rom + ARM patching it, my solution is to use the same rom but just use the 'Bypass save' 'cheat' (lol it's no cheat actually) and not modify the actual ROM at all.
    Modifying and repacking the ROM which happens when you ARM patch it fucked multiplayer up for me. =[

    - Nillus
  4. branraf

    branraf New Member

    Well fair enough then, i have no complaints, playing it now anyways and already completed it ;D Such a good game.
  5. iNillus

    iNillus New Member


    Oh well then I hope it's still useful for people who DO have problems with their arm patched rom or just want a guaranteed working one.
    Thanks. =]

    - Nillus
  6. branraf

    branraf New Member

    Well it should be, saves time going through 32 pages trying to find the solution to the problem heh.
  7. Ryy

    Ryy New Member

    I'm using an R4. But there aren't any cheats available for this game. The latest cheat database on seems to be last modified on March 4th. So that must be the reason. Where do you get a newer updated database?
  8. iNillus

    iNillus New Member

    Yeh they appear to link to an outdated cheat database on their site, but the forum thread there always has the latest one.

    There's cheat databases for all cards there, last update: 20 march. (contains all cheats you need) :)

    - Nillus
  9. iNillus

    iNillus New Member

    <delete this, quoted the main post instead of editing it rofl)
  10. Barathrum

    Barathrum New Member

    last updated march 27
  11. iNillus

    iNillus New Member

    Thanks, updating start post nao. ;P

    - Nillus
  12. Ryy

    Ryy New Member

    Alright. I got the latest cheat database. Turned on the save bypass thing. But the game still won't load. It says it can't find save data thing.
  13. ~7Vath~

    ~7Vath~ New Member

    I have an R4, and i got the patched F'ed up version you keep talking about, and my bro has the cyclods fix which i think works fine...i did everything in the instructions but i cant understand this part..any help?

    is it the real time on/off enable thing?

    its because of what i cant understand
  14. iNillus

    iNillus New Member

    Open up the directory on your flashcard where your .nds roms are, delete the savefile for the game, put the untouched US rom (#3517) in that directory and make sure you have the latest cheat database.
    Then you boot your DS, select the game, bring up the 'select cheats' menu and tick the 'Bypass save' cheat.
    Then make sure the 'Enable cheats' switch is on and run the game, it should work without problems. =]

    - Nillus
  15. anandjones

    anandjones Active Member

    Nice effort.
  16. ~7Vath~

    ~7Vath~ New Member

    hmmm....still >_>

    i have the untouched & CLEAN version
    i downloaded the lastest cheat databased an i activated the cheat and the cheat enable switch when i boot it up it asks for a sav file to be created
    -i chose yes= doesnt work
    - i chose ignore= same

    am i doing anyting else wrong?
    am i missing something?

    i already accidently erased my old gta chinatow wars patched game save(50% eith lots of stuff) because of this >_>....
  17. hahaikke

    hahaikke New Member

    finally Omg thanx!!!

    You are the best!!
    We played like 100 times the muktiplayer and all the time it freezes after 5 somtimes 15minutes
    But here everything works also gangbang and other things
  18. haoz3r

    haoz3r New Member

    oi gta chinatown wars dont work. when i extract the game it says ''winrar diagnostic messages '' mean it dont work wat do i do?
  19. Loonylion

    Loonylion Administrator Staff Member

    delete it and redownload.
  20. Ryy

    Ryy New Member

    I have the problem as 7Vath. I don't know why it's not working. Maybe because I have a Chinese R4?
Thread Status:
Not open for further replies.

Share This Page