R4 SDHC Cheats

Discussion in 'Non-Emulation Help' started by EDX2308, Sep 12, 2008.

  1. EDX2308

    EDX2308 New Member

    Hey everyone! I bought an R4 SDHC not long ago and noticed that the cheat descriptions are all in Chinese. The really weird thing is the cheats work on English games no problem but I sometimes have trouble knowing which codes to put on.

    My question is, is there any files or cheat.dat that I can get that is in English? I tried the one for v1.18 but that doesn't work.
  2. EDX2308

    EDX2308 New Member

    Oh by the way, the cheats I am talking about are the Action Replay codes. Like I said, I pressed the Y button and BAM the game's cheats are all in Chinese. There have been no updates for v1.21 R4 SDHC yet. Not sure if anyone was able to find a way around it.
  3. jc_106

    jc_106 New Member

    I found this on another forums, afterdawn.net (http://forums.afterdawn.com/thread_view.cfm/505999). Let's hope it helps.

    NOTE: the original tutorial was for R4, not R4 SDHC, but I guess it works.

    For cheat files, check http://cheats.gbatemp.net/, they have a large collection, just try them and see if it works. :)

    Hope it helps.
  4. EDX2308

    EDX2308 New Member

    YAHOOOO IT WORKS!!!!!! Thanks buddy! I saw the that post on afterdawn.net but I thought it was too messy..... Actually it's pretty easy. Now my codes are ALL in English description but I haven't tried them out yet. I assume that they would be just fine.

    I imported ALL the cheats from the US cheats from the action replay program. I even got newer ones like Final Fantasy IV.

    Thanks a bunch. I hope this solves most of the R4 SDHC problems. I know the other problem is the multimedia button not working but needed the _DS_MSHL.NDS file imported onto the SD card.

    Good as an original!
  5. jc_106

    jc_106 New Member

    Nice to see that. :)
  6. anandjones

    anandjones Active Member

    Yes the ones that Narin maintains works on R4 as well as a few other flashcarts.
  7. theerapong2002

    theerapong2002 New Member

    Oh God Thanks a lot!!! It' s work!
  8. jules1995

    jules1995 New Member

    I've just tried it and under subscriptions it says load failed. Whenever I try to add a subscription it always says error connecting to subscription source.

    Any ideas on how to fix this?
  9. afrokid13

    afrokid13 New Member

    Probly typed in the wrong the wrong URL
    or maybe theres something wrong with your internet conection
    Which cheat DB are you trying to open in the ARCD?
  10. Fire_Ice

    Fire_Ice Guest

    I find it strange that a firmwire of R4 works on a R4SDHC

    I have a R4 SDHC 4GB and the normal kernel of R4 will not work on my R4

    the newest R4SDHC is kernel 1.26 which has moonshell 2.00 stable with it

    you can find kernel 1.26 here: http://www.r4sdhc.com/download-en.htm
  11. AnxietyTrip

    AnxietyTrip New Member

    Ok i've also been trying to get this to work Ive got a SD HC card im trying to update the cheat codes on. Ive downloaded the latest version 1.21 and when i load it up all 3 boxes "GAME Multimedia and Boot Slot 2" are invisible with just the highlighted marker around them. Ive downloaded a premade Cheat.dat and replaced it with the one that comes in the new version but either one still will not bring up the "Y" to enter cheats on. Do you have to do all the new subscribing to action replay and saving the new file to usrcheat for it to even work?
  12. Fire_Ice

    Fire_Ice Guest

    No i don't think so by reading your post

    it depends on what r4 you have

    I had a R4 SDHC with firmwire 1.26 from r4sdhc.com now
    (my Ds has been stolen so I'd had to order a new one also a new R4)

    I have a r4 SDHC upgrade which means i have a new firmwire from:www.r4rts.cn

    I think you need the cheat.dat file and when you start your DS and you can't see you
    3 boxes "GAME Multimedia and Boot Slot 2" I think you have the wrong firmwire
    for your r4 you must look on you r4 package which site it says to find your firmwire

    if you can't find it i shall name a few sites :

    http://www.r4rts.cn (this is the site for my new R4) -----> this version uses usrcheat.dat
    http://www.r4sdhc.com -------> this version uses cheat.dat

    An other common problem with R4 is not showing its cheats you can solve that by removing
    cheats that you don't use and start with the (J) cheats and most of the time when you shrunk your cheatdatabase it will show its cheats
  13. 88007287

    88007287 New Member

    does anyone know how to play downloaded gba games on the DS.
    Not from boot slot 2 but from the R4.
  14. DaeVon

    DaeVon New Member

    i had the same problem, dont remember the specifics, but now i only keep the usrcheat.dat, cheats dont show up without it, but they do without the cheat.dat, so i said to hell w/ u yor wasting space cheat.dat bitch! lol i wish i could find out if i had a clone or not, most likely is :p
  15. Fire_Ice

    Fire_Ice Guest

    The difference between cheat.dat and USRcheat.dat is that
    USRcheat.dat is not encrypted and cheat.dat is.

    Real R4 must have encryption and Acekard does not because it uses the USRcheat.dat
    and that one is not encrypted
    Post Merge: [time]1269684829[/time]
    Look here for a list of Real R4 and its clones


Share This Page