Disk errorcode=-81 ~TTDS Problem

Discussion in 'Technical Help' started by Kiekoes, Jan 1, 2010.

  1. Kiekoes

    Kiekoes Guest

    Yo guys, I get a weird errorcode with some games, the games should work! I played them before but deleted them and now I felt like playing them again. I get this:
    [Rom loading failed]
    disk errorcode=-81
    Please reset system.


    I'm using 1.17a12 with the latest infolib files (released today!).

    I got this with the following Roms:
    Pokemon Platinum
    Tales of Hearts
    FF Christal Chronicals Echoes of Time

    EDIT: If you have this errorcode, just reformat your MSD! It helps!
     
  2. Jhon 591

    Jhon 591 Active Member

    dsm0129.zip was more updated with thease three files, don't know the changes though

    http://gamewiki.jp/uploader/dsma/

    http://sites.google.com/site/weeklyinfolib/

    it has

    infolib.dat
    extinfo.dat
    savlib.dat

    In the arcive and bigger then the original three files

    Place in ttmenu folder
     
  3. Kiekoes

    Kiekoes Guest

    I know, I update all the time, and when I said: ''The latest infolib files'' I ment dsm0129.
    But sometimes I get that weird errorcode=-81 message. But now everyone can fix it.
     
  4. matty999555

    matty999555 New Member

    I found on my R4i SDHC which is a DSTT clone that deleting any files not included in the firmware download solved this:

    On mine it meant deleting swreset.sys , demon.sys and demon0.sys

    They worked after that.
     
  5. Kiekoes

    Kiekoes Guest

    Wow, what are demon.sys and demon0.sys :O
     
  6. matty999555

    matty999555 New Member

    some files on my R4 clone which are created when I use it. These just remember what the games are and your last played game to speed it up, they are pretty useless and can easiily be deleted.

    These files in addition to stoping certain games from working have made me unable to access my games menu.
     
  7. 159159

    159159 New Member

    Back up your files and reformat your SD
     
  8. Kiekoes

    Kiekoes Guest

    We already figured that out... >.>
     
  9. starwarsman

    starwarsman New Member

    im getting the same error code what would reformating you sd be
     
  10. anandjones

    anandjones Active Member

    Use this tool. http://anandjones.romulation.net/files/misc/pformatter.rar

    It's explained in the Common Issues. http://www.romulation.net/forum/index.php?topic=1462.0
     
  11. Chris_Sonicspeed

    Chris_Sonicspeed New Member

    I deleted demon.sys demon0.sys and swreset.sys and it doent make the file with error work...

    not on r4i sdhc it doesnt
     
  12. Kiekoes

    Kiekoes Guest

    Reformat your MSD!
     
  13. Jhon 591

    Jhon 591 Active Member

    errorcode

    ysmenu error code list and what it means

     
  14. mudkipx

    mudkipx New Member

    i tried reformatting but the games still wont work.. is there any other solution to the -81 error?
     
  15. Jhon 591

    Jhon 591 Active Member

    Lol, Now i know this is BS , It's a arm7 issue , a code hex needs to be found!

    This is right!, Hex code need's to be found to fix the problem like the same with ARM7 abouth
     
  16. Golden890

    Golden890 New Member

    Errrrr, is there no other way to play games that error=4? >.< I reallly wanna play Etrian Oddessy 3.....
     
  17. camygiu

    camygiu Member

    do you try again to put in the games? It happened to me sometimes and usually was a ROM issue
    Post Merge: [time]1288715217[/time]
    wait a fix for that
     

Share This Page